ALPINE-CVE-2019-16201
ALPINE-CVE-2019-16201
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.10
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.5.7-r0
Update to 2.5.7-r0
ruby Alpine:v3.11
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.7
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.10-r0
Update to 2.4.10-r0
ruby Alpine:v3.8
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.5.7-r0
Update to 2.5.7-r0
ruby Alpine:v3.9
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.5.7-r0
Update to 2.5.7-r0