p PatchFirst

PatchFirst · Latest vulnerabilities

ruby vulnerabilities

Vulnerabilities published for ruby in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 29

  1. ALPINE-CVE-2021-32066

    High · CVSS 7.4Fix available

    ALPINE-CVE-2021-32066

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. Net::IMAP does not raise an exception when StartTLS fails with an an unknown response, which might allow man-in-the-middle attackers to bypass the TLS protections by leveraging a network position between the client and the registry to block the StartTLS command, aka a "StartTLS stripping attack."

    • Update to 2.6.8-r0
    Published Updated
  2. ALPINE-CVE-2021-31810

    Medium · CVSS 5.8Fix available

    ALPINE-CVE-2021-31810

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. A malicious FTP server can use the PASV response to trick Net::FTP into connecting back to a given IP address and port. This potentially makes curl extract information about services that are otherwise private and not disclosed (e.g., the attacker can conduct port scans and service banner extractions).

    • Update to 2.6.8-r0
    Published Updated
  3. ALPINE-CVE-2020-25613

    High · CVSS 7.5Fix available

    ALPINE-CVE-2020-25613

    An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

    • Update to 2.6.6-r3
    Published Updated
  4. ALPINE-CVE-2020-10933

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2020-10933

    An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0. If a victim calls BasicSocket#read_nonblock(requested_size, buffer, exception: false), the method resizes the buffer to fit the requested size, but no data is copied. Thus, the buffer string provides the previous value of the heap. This may expose possibly sensitive data from the interpreter.

    • Update to 2.6.6-r0
    Published Updated
  5. ALPINE-CVE-2020-10663

    High · CVSS 7.5Fix available

    ALPINE-CVE-2020-10663

    The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

    • Update to 2.6.6-r0
    Published Updated
  6. ALPINE-CVE-2019-16255

    High · CVSS 8.1Fix available

    ALPINE-CVE-2019-16255

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

    • Update to 2.6.5-r0
    Published Updated
  7. ALPINE-CVE-2019-16254

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2019-16254

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.

    • Update to 2.6.5-r0
    Published Updated
  8. ALPINE-CVE-2019-16201

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-16201

    WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

    • Update to 2.6.5-r0
    Published Updated
  9. ALPINE-CVE-2018-16395

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2018-16395

    An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

    • Update to 2.5.2-r0
    Published Updated
  10. ALPINE-CVE-2018-8780

    Critical · CVSS 9.1Fix available

    ALPINE-CVE-2018-8780

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the Dir.open, Dir.new, Dir.entries and Dir.empty? methods do not check NULL characters. When using the corresponding method, unintentional directory traversal may be performed.

    • Update to 2.5.1-r0
    Published Updated
  11. ALPINE-CVE-2018-8779

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-8779

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the UNIXServer.open and UNIXSocket.open methods are not checked for null characters. It may be connected to an unintended socket.

    • Update to 2.5.1-r0
    Published Updated
  12. ALPINE-CVE-2018-8778

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-8778

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker controlling the unpacking format (similar to format string vulnerabilities) can trigger a buffer under-read in the String#unpack method, resulting in a massive and controlled information disclosure.

    • Update to 2.5.1-r0
    Published Updated
  13. ALPINE-CVE-2018-8777

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-8777

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker can pass a large HTTP request with a crafted header to WEBrick server or a crafted body to WEBrick server/handler and cause a denial of service (memory consumption).

    • Update to 2.5.1-r0
    Published Updated
  14. ALPINE-CVE-2018-6914

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-6914

    Directory traversal vulnerability in the Dir.mktmpdir method in the tmpdir library in Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 might allow attackers to create arbitrary directories or files via a .. (dot dot) in the prefix argument.

    • Update to 2.5.1-r0
    Published Updated
  15. ALPINE-CVE-2017-17742

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2017-17742

    Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 allows an HTTP Response Splitting attack. An attacker can inject a crafted key and value into an HTTP response for the HTTP server of WEBrick.

    • Update to 2.5.1-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →