ALPINE-CVE-2019-16254
ALPINE-CVE-2019-16254
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.
CVSS 5.3 · Medium · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.10
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.5.7-r0
Update to 2.5.7-r0
ruby Alpine:v3.11
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.6.5-r0
Update to 2.6.5-r0
ruby Alpine:v3.7
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.4.10-r0
Update to 2.4.10-r0
ruby Alpine:v3.8
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.5.7-r0
Update to 2.5.7-r0
ruby Alpine:v3.9
- Affected ranges
- ECOSYSTEM: ≥ 2.4.0, < 2.5.7-r0
Update to 2.5.7-r0