ALPINE-CVE-2019-18934
ALPINE-CVE-2019-18934
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Unbound 1.6.4 through 1.9.4 contain a vulnerability in the ipsec module that can cause shell code execution after receiving a specially crafted answer. This issue can only be triggered if unbound was compiled with `--enable-ipsecmod` support, and ipsecmod is enabled and used in the configuration.
CVSS 7.3 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
unbound Alpine:v3.10
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.1-r4
Update to 1.9.1-r4
unbound Alpine:v3.11
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.9.5-r0
Update to 1.9.5-r0
unbound Alpine:v3.8
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.7.3-r2
Update to 1.7.3-r2
unbound Alpine:v3.9
- Affected ranges
- ECOSYSTEM: ≥ 1.6.4, < 1.8.3-r3
Update to 1.8.3-r3