p PatchFirst

ALPINE-CVE-2019-8324

ALPINE-CVE-2019-8324

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

CVSS 8.8 · High · Fix available

Published
Updated

Stack: system

Affected products and versions

  • ruby Alpine:v3.6

    Affected ranges
    • ECOSYSTEM: < 2.4.6-r0

    Update to 2.4.6-r0

  • ruby Alpine:v3.7

    Affected ranges
    • ECOSYSTEM: < 2.4.6-r0

    Update to 2.4.6-r0

  • ruby Alpine:v3.8

    Affected ranges
    • ECOSYSTEM: < 2.5.5-r0

    Update to 2.5.5-r0

  • ruby Alpine:v3.9

    Affected ranges
    • ECOSYSTEM: < 2.5.5-r0

    Update to 2.5.5-r0

Original sources

Check your server →