p PatchFirst

PatchFirst · Latest vulnerabilities

ruby vulnerabilities

Vulnerabilities published for ruby in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 23

  1. ALPINE-CVE-2019-8323

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-8323

    An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.

    • Update to 2.4.6-r0
    Published Updated
  2. ALPINE-CVE-2019-8322

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-8322

    An issue was discovered in RubyGems 2.6 and later through 3.0.2. The gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.

    • Update to 2.4.6-r0
    Published Updated
  3. ALPINE-CVE-2019-8324

    High · CVSS 8.8Fix available

    ALPINE-CVE-2019-8324

    An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

    • Update to 2.4.6-r0
    Published Updated
  4. ALPINE-CVE-2019-8320

    High · CVSS 7.4Fix available

    ALPINE-CVE-2019-8320

    A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.

    • Update to 2.4.6-r0
    Published Updated
  5. ALPINE-CVE-2018-16395

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2018-16395

    An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

    • Update to 2.4.5-r0
    Published Updated
  6. ALPINE-CVE-2018-8780

    Critical · CVSS 9.1Fix available

    ALPINE-CVE-2018-8780

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the Dir.open, Dir.new, Dir.entries and Dir.empty? methods do not check NULL characters. When using the corresponding method, unintentional directory traversal may be performed.

    • Update to 2.4.4-r0
    Published Updated
  7. ALPINE-CVE-2018-8779

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-8779

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, the UNIXServer.open and UNIXSocket.open methods are not checked for null characters. It may be connected to an unintended socket.

    • Update to 2.4.4-r0
    Published Updated
  8. ALPINE-CVE-2018-8778

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-8778

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker controlling the unpacking format (similar to format string vulnerabilities) can trigger a buffer under-read in the String#unpack method, resulting in a massive and controlled information disclosure.

    • Update to 2.4.4-r0
    Published Updated
  9. ALPINE-CVE-2018-8777

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-8777

    In Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1, an attacker can pass a large HTTP request with a crafted header to WEBrick server or a crafted body to WEBrick server/handler and cause a denial of service (memory consumption).

    • Update to 2.4.4-r0
    Published Updated
  10. ALPINE-CVE-2018-6914

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-6914

    Directory traversal vulnerability in the Dir.mktmpdir method in the tmpdir library in Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 might allow attackers to create arbitrary directories or files via a .. (dot dot) in the prefix argument.

    • Update to 2.4.4-r0
    Published Updated
  11. ALPINE-CVE-2017-17742

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2017-17742

    Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 allows an HTTP Response Splitting attack. An attacker can inject a crafted key and value into an HTTP response for the HTTP server of WEBrick.

    • Update to 2.4.4-r0
    Published Updated
  12. ALPINE-CVE-2017-17405

    High · CVSS 8.8Fix available

    ALPINE-CVE-2017-17405

    Ruby before 2.4.3 allows Net::FTP command injection. Net::FTP#get, getbinaryfile, gettextfile, put, putbinaryfile, and puttextfile use Kernel#open to open a local file. If the localfile argument starts with the "|" pipe character, the command following the pipe character is executed. The default value of localfile is File.basename(remotefile), so malicious FTP servers could cause arbitrary command execution.

    • Update to 2.4.3-r0
    Published Updated
  13. ALPINE-CVE-2017-10784

    High · CVSS 8.8Fix available

    ALPINE-CVE-2017-10784

    The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name.

    • Update to 2.4.2-r0
    Published Updated
  14. ALPINE-CVE-2017-0898

    Critical · CVSS 9.1Fix available

    ALPINE-CVE-2017-0898

    Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

    • Update to 2.4.2-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →