ALPINE-CVE-2020-25613
ALPINE-CVE-2020-25613
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.10
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.5.8-r1
Update to 2.5.8-r1
ruby Alpine:v3.11
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.6.6-r3
Update to 2.6.6-r3
ruby Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0
ruby Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.2-r0
Update to 2.7.2-r0