ALPINE-CVE-2021-37600
ALPINE-CVE-2021-37600
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An integer overflow in util-linux through 2.37.1 can potentially cause a buffer overflow if an attacker were able to use system resources in a way that leads to a large number in the /proc/sysvipc/sem file. NOTE: this is unexploitable in GNU C Library environments, and possibly in all realistic environments.
CVSS 5.5 · Medium · Fix available
- Published
- Updated
Stack: system
Affected products and versions
util-linux Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0
util-linux Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.37.2-r0
Update to 2.37.2-r0