p PatchFirst

PatchFirst · Latest vulnerabilities

util-linux vulnerabilities

Vulnerabilities published for util-linux in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. ALPINE-CVE-2021-3996

    Medium · CVSS 5.5Fix available

    ALPINE-CVE-2021-3996

    A logic error was found in the libmount library of util-linux in the function that allows an unprivileged user to unmount a FUSE filesystem. This flaw allows a local user on a vulnerable system to unmount other users' filesystems that are either world-writable themselves (like /tmp) or mounted in a world-writable directory. An attacker may use this flaw to cause a denial of service to applications that use the affected filesystems.

    • Update to 2.37.3-r0
    Published Updated
  2. ALPINE-CVE-2021-3995

    Medium · CVSS 5.5Fix available

    ALPINE-CVE-2021-3995

    A logic error was found in the libmount library of util-linux in the function that allows an unprivileged user to unmount a FUSE filesystem. This flaw allows an unprivileged local attacker to unmount FUSE filesystems that belong to certain other users who have a UID that is a prefix of the UID of the attacker in its string form. An attacker may use this flaw to cause a denial of service to applications that use the affected filesystems.

    • Update to 2.37.3-r0
    Published Updated
  3. ALPINE-CVE-2022-0563

    Medium · CVSS 5.5Fix available

    ALPINE-CVE-2022-0563

    A flaw was found in the util-linux chfn and chsh utilities when compiled with Readline support. The Readline library uses an "INPUTRC" environment variable to get a path to the library config file. When the library cannot parse the specified file, it prints an error message containing data from the file. This flaw allows an unprivileged user to read root-owned files, potentially leading to privilege escalation. This flaw affects util-linux versions prior to 2.37.4.

    • Update to 2.37.4-r0
    Published Updated
  4. ALPINE-CVE-2021-37600

    Medium · CVSS 5.5Fix available

    ALPINE-CVE-2021-37600

    An integer overflow in util-linux through 2.37.1 can potentially cause a buffer overflow if an attacker were able to use system resources in a way that leads to a large number in the /proc/sysvipc/sem file. NOTE: this is unexploitable in GNU C Library environments, and possibly in all realistic environments.

    • Update to 2.37.2-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →