ALPINE-CVE-2021-3996
ALPINE-CVE-2021-3996
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A logic error was found in the libmount library of util-linux in the function that allows an unprivileged user to unmount a FUSE filesystem. This flaw allows a local user on a vulnerable system to unmount other users' filesystems that are either world-writable themselves (like /tmp) or mounted in a world-writable directory. An attacker may use this flaw to cause a denial of service to applications that use the affected filesystems.
CVSS 5.5 · Medium · Fix available
- Published
- Updated
Stack: system
Affected products and versions
util-linux Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0
util-linux Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.34, < 2.37.3-r0
Update to 2.37.3-r0