ALPINE-CVE-2021-41817
ALPINE-CVE-2021-41817
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string. The fixed versions are 3.2.1, 3.1.2, 3.0.2, and 2.0.1.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby Alpine:v3.12
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.5-r0
Update to 2.7.5-r0
ruby Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.5-r0
Update to 2.7.5-r0
ruby Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 2.7.5-r0
Update to 2.7.5-r0
ruby Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0
ruby Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0
Update to 3.0.3-r0