p PatchFirst

ALPINE-CVE-2021-41817

ALPINE-CVE-2021-41817

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string. The fixed versions are 3.2.1, 3.1.2, 3.0.2, and 2.0.1.

CVSS 7.5 · Hoch · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • ruby Alpine:v3.12

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 2.7.5-r0

    Auf 2.7.5-r0 aktualisieren

  • ruby Alpine:v3.13

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 2.7.5-r0

    Auf 2.7.5-r0 aktualisieren

  • ruby Alpine:v3.14

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 2.7.5-r0

    Auf 2.7.5-r0 aktualisieren

  • ruby Alpine:v3.15

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.16

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.17

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.18

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.19

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.20

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.21

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.22

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.23

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

  • ruby Alpine:v3.24

    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.6.0, < 3.0.3-r0

    Auf 3.0.3-r0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →