ALPINE-CVE-2022-22707
ALPINE-CVE-2022-22707
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.
CVSS 5.9 · Medium · Fix available
- Published
- Updated
Stack: system
Affected products and versions
lighttpd Alpine:v3.13
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.14
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.15
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.16
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.17
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.18
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.19
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.20
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.21
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.22
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.23
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0
lighttpd Alpine:v3.24
- Affected ranges
- ECOSYSTEM: ≥ 1.4.46, < 1.4.64-r0
Update to 1.4.64-r0