p PatchFirst

PatchFirst · Latest vulnerabilities

lighttpd vulnerabilities

Vulnerabilities published for lighttpd in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1

  1. ALPINE-CVE-2022-22707

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2022-22707

    In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.

    • Update to 1.4.64-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →