ALPINE-CVE-2023-52425
ALPINE-CVE-2023-52425
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libexpat through 2.5.0 allows a denial of service (resource consumption) because many full reparsings are required in the case of a large token for which multiple buffer fills are needed.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
expat Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0
expat Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0
expat Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0
expat Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0
expat Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0
expat Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0
expat Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0
expat Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0
expat Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.6.0-r0
Update to 2.6.0-r0