p PatchFirst

PatchFirst · Latest vulnerabilities

expat vulnerabilities

Vulnerability published for expat in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 56

  1. ALPINE-CVE-2026-77214

    High · CVSS 8.3Fix available

    ALPINE-CVE-2026-77214

    libexpat before commit 13c5f63 contains a heap buffer over-read vulnerability in xmlparse.c. XML_ParseBuffer advances the parse buffer end with parser->m_bufferEnd += len using a caller-supplied length that is not validated against the allocated buffer size, so repeated XML_ParseBuffer calls move m_bufferEnd past the end of the heap allocation and subsequent parsing reads out of bounds. Reaching this path requires a parse buffer to already be present; otherwise XML_ParseBuffer returns XML_ERROR_NO_BUFFER. A buffer is present after a prior call to XML_GetBuffer, either directly (the common case) or indirectly through a prior XML_Parse call tha

    • Update to 2.9.0-r0
    Published Updated
  2. ALPINE-CVE-2026-102633

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2026-102633

    libexpat versions 2.7.2 through 2.8.5 contain an integer overflow vulnerability in expat_realloc() function on 32-bit platforms when computing allocation sizes. Attackers supplying malicious XML to applications parsing with vulnerable libexpat can cause heap buffer overflow, memory corruption, or denial of service.

    • Update to 2.9.0-r0
    Published Updated
  3. ALPINE-CVE-2026-93990

    High · CVSS 8.7Fix available

    ALPINE-CVE-2026-93990

    Expat before 2.8.5 fails to validate that a high surrogate in UTF-16 input is followed by a low surrogate, allowing malformed UTF-16 sequences to be accepted. Attackers can supply UTF-16 encoded XML containing lone high surrogates that consume the following code unit, causing Expat to pass unpaired surrogates to applications built with XML_UNICODE and to silently replace input characters in other builds.

    • Update to 2.8.5-r0
    Published Updated
  4. ALPINE-CVE-2026-76641

    High · CVSS 8.7Fix available

    ALPINE-CVE-2026-76641

    Expat through 2.8.3 contains an out-of-bounds read vulnerability that allows attackers to trigger memory corruption by processing XML with external entity parsers created via XML_ExternalEntityParserCreate. A struct size mismatch between ELEMENT_TYPE members causes storeAtts to read the attIndex member past allocated memory boundaries, resulting in failure to normalize whitespace in non-CDATA attributes or a wild pointer dereference causing a segfault. This vulnerability was introduced by the fix for CVE-2026-66046.

    • Update to 2.8.4-r0
    Published Updated
  5. ALPINE-CVE-2026-76956

    High · CVSS 7.5Fix available

    ALPINE-CVE-2026-76956

    In libexpat 2.8.2 and 2.8.3 before 2.8.4, misinterpretation of getentropy's return code leads to insufficient entropy, which results in being vulnerable to hash flooding attacks, causing a denial of service via crafted XML content.

    • Update to 2.8.4-r0
    Published Updated
  6. ALPINE-CVE-2026-66046

    High · CVSS 8.7Fix available

    ALPINE-CVE-2026-66046

    Expat through 2.8.3 contains a denial of service vulnerability caused by quadratic algorithmic complexity in the storeAtts() function in xmlparse.c, where processing N specified attributes with non-normalized values triggers an O(N^2) linear scan of elementType->defaultAtts to determine CDATA status. A remote unauthenticated attacker can supply a single well-formed XML document of a few megabytes to an application parsing untrusted XML to cause excessive CPU consumption, resulting in denial of service without requiring authentication, external entity resolution, or non-default parser options.

    • Update to 2.8.4-r0
    Published Updated
  7. ALPINE-CVE-2026-56412

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2026-56412

    libexpat before 2.8.2 does not consider XML_TOK_DATA_CHARS in doCdataSection and thus lacks handler call depth tracking for various calls from within handlers in cases of a policy violation. Thus, a use-after-free can occur. NOTE: this issue exists because of an incomplete fix for CVE-2026-50219.

    • Update to 2.8.2-r0
    Published Updated
  8. ALPINE-CVE-2026-50219

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2026-50219

    libexpat before 2.8.2 lacks handler call depth tracking for calls to XML_GetBuffer, XML_Parse, XML_ParseBuffer, XML_ParserFree, or XML_ParserReset from within handlers in cases of a policy violation. Thus, a use-after-free can occur,

    • Update to 2.8.2-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →