ALPINE-CVE-2024-8176
ALPINE-CVE-2024-8176
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A stack overflow vulnerability exists in the libexpat library due to the way it handles recursive entity expansion in XML documents. When parsing an XML document with deeply nested entity references, libexpat can be forced to recurse indefinitely, exhausting the stack space and causing a crash. This issue could lead to denial of service (DoS) or, in some cases, exploitable memory corruption, depending on the environment and library usage.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
expat Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.7.0-r0
Update to 2.7.0-r0
expat Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.7.0-r0
Update to 2.7.0-r0
expat Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.7.0-r0
Update to 2.7.0-r0
expat Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.7.0-r0
Update to 2.7.0-r0
expat Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.7.0-r0
Update to 2.7.0-r0
expat Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.7.0-r0
Update to 2.7.0-r0
expat Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.7.0-r0
Update to 2.7.0-r0