p PatchFirst

ALPINE-CVE-2026-41080

ALPINE-CVE-2026-41080

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libexpat before 2.8.0 uses insufficient entropy, and thus hash flooding can occur via a crafted XML document.

CVSS 2.9 · Low · Fix available

Published
Updated

Stack: system

Affected products and versions

  • expat Alpine:v3.20

    Affected ranges
    • ECOSYSTEM: < 2.8.1-r0

    Update to 2.8.1-r0

  • expat Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 2.8.1-r0

    Update to 2.8.1-r0

  • expat Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 2.8.1-r0

    Update to 2.8.1-r0

  • expat Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 2.8.1-r0

    Update to 2.8.1-r0

  • expat Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 2.8.0-r0

    Update to 2.8.0-r0

Original sources

Check your server →