ALPINE-CVE-2026-42356
ALPINE-CVE-2026-42356
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by mod_mime. This issue affects Apache HTTP Server: from 2.4.60 through 2.4.68.
CVSS 3.7 · Low · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.69-r0
Update to 2.4.69-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.69-r0
Update to 2.4.69-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.69-r0
Update to 2.4.69-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.69-r0
Update to 2.4.69-r0