p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities

Vulnerabilities published for apache2 in the last 30 days: 20. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 144

  1. ALPINE-CVE-2026-93546

    High · CVSS 8.8Fix available

    ALPINE-CVE-2026-93546

    Integer overflow in mod_dav_fs in Apache HTTP Server through 2.4.68 allows an authenticated WebDAV client with write access to crash worker processes and persistently corrupt a directory's property database via PROPPATCH requests declaring many XML namespaces.

    • Update to 2.4.69-r0
    Published Updated
  2. ALPINE-CVE-2026-73637

    High · CVSS 7.3Fix available

    ALPINE-CVE-2026-73637

    Use after free in mod_auth_digest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause authentication state corruption via concurrent Digest authentication requests when AuthDigestNcCheck is enabled or AuthDigestNonceLifetime is set to 0. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

    • Update to 2.4.69-r0
    Published Updated
  3. ALPINE-CVE-2026-79768

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2026-79768

    Path equivalence: '/./' (single dot directory) vulnerability in Apache HTTP Server's mod_userdir module when configured with absolute non-wildcard UserDir directive (the 2nd form in https://httpd.apache.org/docs/2.4/mod/mod_userdir.html#userdir) This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

    • Update to 2.4.69-r0
    Published Updated
  4. ALPINE-CVE-2026-73636

    High · CVSS 8.1Fix available

    ALPINE-CVE-2026-73636

    Authentication bypass by capture-replay in mod_auth_digest in Apache Software Foundation Apache HTTP Server 2.4.x on all platforms allows a man-in-the-middle (MITM) attacker to replay captured digest authentication credentials via crafted requests that trigger garbage collection of the client's shared memory entry when AuthDigestNonceLifetime is set to 0. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

    • Update to 2.4.69-r0
    Published Updated
  5. ALPINE-CVE-2026-63718

    High · CVSS 7.5Fix available

    ALPINE-CVE-2026-63718

    Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') response smuggling vulnerability in Apache HTTP Server via mod_proxy_uwsgi and a crafted uwsgi response with Transfer-Encoding. This issue affects Apache HTTP Server: from 2.4.30 through 2.4.68.

    • Update to 2.4.69-r0
    Published Updated
  6. ALPINE-CVE-2026-63686

    High · CVSS 7.5Fix available

    ALPINE-CVE-2026-63686

    A NULL pointer dereference in mod_xml2enc in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an untrusted backend server to cause a denial of service via a proxied response with a charset whose conversion partially succeeds then fails. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

    • Update to 2.4.69-r0
    Published Updated
  7. ALPINE-CVE-2026-63292

    High · CVSS 7.5Fix available

    ALPINE-CVE-2026-63292

    Stack-based buffer overflow in mod_vhost_alias in Apache Software Foundation Apache HTTP Server through 2.4.68 on all platforms allows a remote client to cause a denial of service or potentially execute arbitrary code via an HTTP request with a Host header exceeding 8192 bytes when VirtualDocumentRoot uses a hostname format specifier and LimitRequestFieldSize is raised above the default. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

    • Update to 2.4.69-r0
    Published Updated
  8. ALPINE-CVE-2026-63045

    High · CVSS 7.5Fix available

    ALPINE-CVE-2026-63045

    Improper validation of FTP PASV reply address in mod_proxy_ftp in Apache Software Foundation Apache HTTP Server through 2.4.68 on all platforms allows, in forward proxy configurations, an untrusted FTP server to cause the proxy to open a data connection to an arbitrary third-party host via a crafted PASV response. Users are recommended to upgrade to version 2.4.69, which fixes this issue.

    • Update to 2.4.69-r0
    Published Updated
  9. ALPINE-CVE-2026-58415

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2026-58415

    Internal state files accessible to external parties in mod_dav_fs in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows a remote client to read WebDAV dead properties of resources it cannot author via a GET request for the .DAV state directory This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

    • Update to 2.4.69-r0
    Published Updated
  10. ALPINE-CVE-2026-48005

    High · CVSS 7.5Fix available

    ALPINE-CVE-2026-48005

    Missing authentication checks in mod_auth_digest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause a denial of service (forced re-authentication) via forged Authorization headers when Digest authentication is enabled with AuthDigestNcCheck . Users are recommended to upgrade to version 2.4.69, which fixes this issue.

    • Update to 2.4.69-r0
    Published Updated
  11. ALPINE-CVE-2026-47360

    High · CVSS 7.5Fix available

    ALPINE-CVE-2026-47360

    Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache HTTP Server's mod_session_cookie module.   When SessionCookieRemove changes across internal redirects, the session cookie may still be passed to a backend server. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

    • Update to 2.4.69-r0
    Published Updated
  12. ALPINE-CVE-2026-42528

    Medium · CVSS 4.3Fix available

    ALPINE-CVE-2026-42528

    A memory calculation bug in mod_dav in Apache httpd 2.4.67 and earlier allows an attacker with permission to create WebDAV locks to crash server child processes. Users are recommended to upgrade to version 2.4.69, which fixes this issue

    • Update to 2.4.69-r0
    Published Updated
  13. ALPINE-CVE-2026-42356

    Low · CVSS 3.7Fix available

    ALPINE-CVE-2026-42356

    Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by mod_mime. This issue affects Apache HTTP Server: from 2.4.60 through 2.4.68.

    • Update to 2.4.69-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →