p PatchFirst

ALPINE-CVE-2026-56154

ALPINE-CVE-2026-56154

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Use After Free vulnerability in Apache HTTP Server's mod_rewrite when using lookahead (%{LA-U:HTTP:...}) This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.

CVSS 9.8 · Critical · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache2 Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 2.4.69-r0

    Update to 2.4.69-r0

  • apache2 Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 2.4.69-r0

    Update to 2.4.69-r0

  • apache2 Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 2.4.69-r0

    Update to 2.4.69-r0

  • apache2 Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 2.4.69-r0

    Update to 2.4.69-r0

Original sources

Check your server →