p PatchFirst

PatchFirst · Latest vulnerabilities

nghttp2 vulnerabilities

Vulnerabilities published for nghttp2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. ALPINE-CVE-2020-11080

    High · CVSS 7.5Fix available

    ALPINE-CVE-2020-11080

    In nghttp2 before version 1.41.0, the overly large HTTP/2 SETTINGS frame payload causes denial of service. The proof of concept attack involves a malicious client constructing a SETTINGS frame with a length of 14,400 bytes (2400 individual settings entries) over and over again. The attack causes the CPU to spike at 100%. nghttp2 v1.41.0 fixes this vulnerability. There is a workaround to this vulnerability. Implement nghttp2_on_frame_recv_callback callback, and if received frame is SETTINGS frame and the number of settings entries are large (e.g., > 32), then drop the connection.

    • Update to 1.40.0-r1
    Published Updated
  2. ALPINE-CVE-2019-9513

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-9513

    Some HTTP/2 implementations are vulnerable to resource loops, potentially leading to a denial of service. The attacker creates multiple request streams and continually shuffles the priority of the streams in a way that causes substantial churn to the priority tree. This can consume excess CPU.

    • Update to 1.39.2-r0
    Published Updated
  3. ALPINE-CVE-2019-9511

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-9511

    Some HTTP/2 implementations are vulnerable to window size manipulation and stream prioritization manipulation, potentially leading to a denial of service. The attacker requests a large amount of data from a specified resource over multiple streams. They manipulate window size and stream priority to force the server to queue the data in 1-byte chunks. Depending on how efficiently this data is queued, this can consume excess CPU, memory, or both.

    • Update to 1.39.2-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →