p PatchFirst

PatchFirst · Latest vulnerabilities

python3 vulnerabilities

Vulnerabilities published for python3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 9

  1. ALPINE-CVE-2021-23336

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2021-23336

    The package python/cpython from 0 and before 3.6.13, from 3.7.0 and before 3.7.10, from 3.8.0 and before 3.8.8, from 3.9.0 and before 3.9.2 are vulnerable to Web Cache Poisoning via urllib.parse.parse_qsl and urllib.parse.parse_qs by using a vector called parameter cloaking. When the attacker can separate query parameters using a semicolon (;), they can cause a difference in the interpretation of the request between the proxy (running with default configuration) and the server. This can result in malicious requests being cached as completely safe ones, as the proxy would usually not see the semicolon as a separator, and therefore would not in

    • Update to 3.8.8-r0
    Published Updated
  2. ALPINE-CVE-2021-3177

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-3177

    Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrusted input, as demonstrated by a 1e300 argument to c_double.from_param. This occurs because sprintf is used unsafely.

    • Update to 3.8.7-r1
    Published Updated
  3. ALPINE-CVE-2020-14422

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2020-14422

    Lib/ipaddress.py in Python through 3.8.3 improperly computes hash values in the IPv4Interface and IPv6Interface classes, which might allow a remote attacker to cause a denial of service if an application is affected by the performance of a dictionary containing IPv4Interface or IPv6Interface objects, and this attacker can cause many dictionary entries to be created. This is fixed in: v3.5.10, v3.5.10rc1; v3.6.12; v3.7.9; v3.8.4, v3.8.4rc1, v3.8.5, v3.8.6, v3.8.6rc1; v3.9.0, v3.9.0b4, v3.9.0b5, v3.9.0rc1, v3.9.0rc2.

    • Update to 3.8.4-r0
    Published Updated
  4. ALPINE-CVE-2020-8492

    Medium · CVSS 6.5Fix available

    ALPINE-CVE-2020-8492

    Python 2.7 through 2.7.17, 3.5 through 3.5.9, 3.6 through 3.6.10, 3.7 through 3.7.6, and 3.8 through 3.8.1 allows an HTTP server to conduct Regular Expression Denial of Service (ReDoS) attacks against a client because of urllib.request.AbstractBasicAuthHandler catastrophic backtracking.

    • Update to 3.8.2-r0
    Published Updated
  5. ALPINE-CVE-2020-8315

    Medium · CVSS 5.5Fix available

    ALPINE-CVE-2020-8315

    In Python (CPython) 3.6 through 3.6.10, 3.7 through 3.7.6, and 3.8 through 3.8.1, an insecure dependency load upon launch on Windows 7 may result in an attacker's copy of api-ms-win-core-path-l1-1-0.dll being loaded and used instead of the system's copy. Windows 8 and later are unaffected.

    • Update to 3.8.2-r0
    Published Updated
  6. ALPINE-CVE-2019-5010

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-5010

    An exploitable denial-of-service vulnerability exists in the X509 certificate parser of Python.org Python 2.7.11 / 3.6.6. A specially crafted X509 certificate can cause a NULL pointer dereference, resulting in a denial of service. An attacker can initiate or accept TLS connections using crafted certificates to trigger this vulnerability.

    • Update to 3.6.8-r1
    Published Updated
  7. ALPINE-CVE-2019-16935

    Medium · CVSS 6.1Fix available

    ALPINE-CVE-2019-16935

    The documentation XML-RPC server in Python through 2.7.16, 3.x through 3.6.9, and 3.7.x through 3.7.4 has XSS via the server_title field. This occurs in Lib/DocXMLRPCServer.py in Python 2.x, and in Lib/xmlrpc/server.py in Python 3.x. If set_server_title is called with untrusted input, arbitrary JavaScript can be delivered to clients that visit the http URL for this server.

    • Update to 3.7.5-r0
    Published Updated
  8. ALPINE-CVE-2019-16056

    High · CVSS 7.5Fix available

    ALPINE-CVE-2019-16056

    An issue was discovered in Python through 2.7.16, 3.x through 3.5.7, 3.6.x through 3.6.9, and 3.7.x through 3.7.4. The email module wrongly parses email addresses that contain multiple @ characters. An application that uses the email module and implements some kind of checks on the From/To headers of a message could be tricked into accepting an email address that should be denied. An attack may be the same as in CVE-2019-11340; however, this CVE applies to Python more generally.

    • Update to 3.7.5-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →