p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities · Page 5

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 88

  1. ALPINE-CVE-2017-15715

    High · CVSS 8.1Fix available

    ALPINE-CVE-2017-15715

    In Apache httpd 2.4.0 to 2.4.29, the expression specified in <FilesMatch> could match '$' to a newline character in a malicious filename, rather than matching only the end of the filename. This could be exploited in environments where uploads of some files are are externally blocked, but only by matching the trailing portion of the filename.

    • Update to 2.4.33-r0
    Published Updated
  2. ALPINE-CVE-2017-15710

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-15710

    In Apache httpd 2.0.23 to 2.0.65, 2.2.0 to 2.2.34, and 2.4.0 to 2.4.29, mod_authnz_ldap, if configured with AuthLDAPCharsetConfig, uses the Accept-Language header value to lookup the right charset encoding when verifying the user's credentials. If the header value is not present in the charset conversion table, a fallback mechanism is used to truncate it to a two characters value to allow a quick retry (for example, 'en-US' is truncated to 'en'). A header value of less than two characters forces an out of bound write of one NUL byte to a memory location that is not part of the string. In the worst case, quite unlikely, the process would crash

    • Update to 2.4.33-r0
    Published Updated
  3. ALPINE-CVE-2017-9798

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-9798

    Apache httpd allows remote attackers to read secret data from process memory if the Limit directive can be set in a user's .htaccess file, or if httpd.conf has certain misconfigurations, aka Optionsbleed. This affects the Apache HTTP Server through 2.2.34 and 2.4.x through 2.4.27. The attacker sends an unauthenticated OPTIONS HTTP request when attempting to read secret data. This is a use-after-free issue and thus secret data is not always sent, and the specific data depends on many factors including configuration. Exploitation with .htaccess can be blocked with a patch to the ap_limit_section function in server/core.c.

    • Update to 2.4.27-r1
    Published Updated
  4. ALPINE-CVE-2017-7668

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-7668

    The HTTP strict parsing changes added in Apache httpd 2.2.32 and 2.4.24 introduced a bug in token list parsing, which allows ap_find_token() to search past the end of its input string. By maliciously crafting a sequence of request headers, an attacker may be able to cause a segmentation fault, or to force ap_find_token() to return an incorrect value.

    • Update to 2.4.26-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →