ALPINE-CVE-2017-3167
ALPINE-CVE-2017-3167
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the ap_get_basic_auth_pw() by third-party modules outside of the authentication phase may lead to authentication requirements being bypassed.
CVSS 9.8 · Critical · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.10
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.11
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.12
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.13
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.14
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.15
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.16
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.17
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.18
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.19
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.3
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.4
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.5
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.6
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.7
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.8
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0
apache2 Alpine:v3.9
- Affected ranges
- ECOSYSTEM: < 2.4.26-r0
Update to 2.4.26-r0