p PatchFirst

PatchFirst · Latest vulnerabilities

python3 vulnerabilities

Vulnerabilities published for python3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 24

  1. ALPINE-CVE-2025-4516

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2025-4516

    There is an issue in CPython when using `bytes.decode("unicode_escape", error="ignore|replace")`. If you are not using the "unicode_escape" encoding or an error handler your usage is not affected. To work-around this issue you may stop using the error= handler and instead wrap the bytes.decode() call in a try-except catching the DecodeError.

    • Update to 3.11.12-r1
    Published Updated
  2. ALPINE-CVE-2025-0938

    Medium · CVSS 6.3Fix available

    ALPINE-CVE-2025-0938

    The Python standard library functions `urllib.parse.urlsplit` and `urlparse` accepted domain names that included square brackets which isn't valid according to RFC 3986. Square brackets are only meant to be used as delimiters for specifying IPv6 and IPvFuture hosts in URLs. This could result in differential parsing across the Python URL parser and other specification-compliant URL parsers.

    • Update to 3.11.12-r0
    Published Updated
  3. ALPINE-CVE-2024-9287

    High · CVSS 7.8Fix available

    ALPINE-CVE-2024-9287

    A vulnerability has been found in the CPython `venv` module and CLI where path names provided when creating a virtual environment were not quoted properly, allowing the creator to inject commands into virtual environment "activation" scripts (ie "source venv/bin/activate"). This means that attacker-controlled virtual environments are able to run commands when the virtual environment is activated. Virtual environments which are not created by an attacker or which aren't activated before being used (ie "./venv/bin/python") are not affected.

    • Update to 3.11.11-r0
    Published Updated
  4. ALPINE-CVE-2024-8088

    High · CVSS 8.7Fix available

    ALPINE-CVE-2024-8088

    There is a HIGH severity vulnerability affecting the CPython "zipfile" module affecting "zipfile.Path". Note that the more common API "zipfile.ZipFile" class is unaffected. When iterating over names of entries in a zip archive (for example, methods of "zipfile.Path" like "namelist()", "iterdir()", etc) the process can be put into an infinite loop with a maliciously crafted zip archive. This defect applies when reading only metadata or extracting the contents of the zip archive. Programs that are not handling user-controlled zip archives are not affected.

    • Update to 3.11.8-r1
    Published Updated
  5. ALPINE-CVE-2024-7592

    High · CVSS 7.5Fix available

    ALPINE-CVE-2024-7592

    There is a LOW severity vulnerability affecting CPython, specifically the 'http.cookies' standard library module. When parsing cookies that contained backslashes for quoted characters in the cookie value, the parser would use an algorithm with quadratic complexity, resulting in excess CPU resources being used while parsing the value.

    • Update to 3.11.10-r0
    Published Updated
  6. ALPINE-CVE-2024-4032

    High · CVSS 7.5Fix available

    ALPINE-CVE-2024-4032

    The “ipaddress” module contained incorrect information about whether certain IPv4 and IPv6 addresses were designated as “globally reachable” or “private”. This affected the is_private and is_global properties of the ipaddress.IPv4Address, ipaddress.IPv4Network, ipaddress.IPv6Address, and ipaddress.IPv6Network classes, where values wouldn’t be returned in accordance with the latest information from the IANA Special-Purpose Address Registries. CPython 3.12.4 and 3.13.0a6 contain updated information from these registries and thus have the intended behavior.

    • Update to 3.11.10-r0
    Published Updated
  7. ALPINE-CVE-2023-40217

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2023-40217

    An issue was discovered in Python before 3.8.18, 3.9.x before 3.9.18, 3.10.x before 3.10.13, and 3.11.x before 3.11.5. It primarily affects servers (such as HTTP servers) that use TLS client authentication. If a TLS server-side socket is created, receives data into the socket buffer, and then is closed quickly, there is a brief window where the SSLSocket instance will detect the socket as "not connected" and won't initiate a handshake, but buffered data will still be readable from the socket buffer. This data will not be authenticated if the server-side TLS peer is expecting client certificate authentication, and is indistinguishable from val

    • Update to 3.11.5-r0
    Published Updated
  8. ALPINE-CVE-2023-27043

    Medium · CVSS 5.3Fix available

    ALPINE-CVE-2023-27043

    The email module of Python through 3.11.3 incorrectly parses e-mail addresses that contain a special character. The wrong portion of an RFC2822 header is identified as the value of the addr-spec. In some applications, an attacker can bypass a protection mechanism in which application access is granted only after verifying receipt of e-mail to a specific domain (e.g., only @company.example.com addresses may be used for signup). This occurs in email/_parseaddr.py in recent versions of Python.

    • Update to 3.11.10-r0
    Published Updated
  9. ALPINE-CVE-2022-45061

    High · CVSS 7.5Fix available

    ALPINE-CVE-2022-45061

    An issue was discovered in Python before 3.11.1. An unnecessary quadratic algorithm exists in one path when processing some inputs to the IDNA (RFC 3490) decoder, such that a crafted, unreasonably long name being presented to the decoder could lead to a CPU denial of service. Hostnames are often supplied by remote servers that could be controlled by a malicious actor; in such a scenario, they could trigger excessive CPU consumption on the client attempting to make use of an attacker-supplied supposed hostname. For example, the attack payload could be placed in the Location header of an HTTP response with status code 302. A fix is planned in 3

    • Update to 3.11.1-r0
    Published Updated
  10. ALPINE-CVE-2015-20107

    High · CVSS 7.6Fix available

    ALPINE-CVE-2015-20107

    In Python (aka CPython) up to 3.10.8, the mailcap module does not add escape characters into commands discovered in the system mailcap file. This may allow attackers to inject shell commands into applications that call mailcap.findmatch with untrusted input (if they lack validation of user-provided filenames or arguments). The fix is also back-ported to 3.7, 3.8, 3.9

    • Update to 3.10.5-r0
    Published Updated
  11. ALPINE-CVE-2021-3426

    Medium · CVSS 5.7Fix available

    ALPINE-CVE-2021-3426

    There's a flaw in Python 3's pydoc. A local or adjacent attacker who discovers or is able to convince another local or adjacent user to start a pydoc server could access the server and use it to disclose sensitive information belonging to the other user that they would not normally be able to access. The highest risk of this flaw is to data confidentiality. This flaw affects Python versions before 3.8.9, Python versions before 3.9.3 and Python versions before 3.10.0a7.

    • Update to 3.9.4-r0
    Published Updated
  12. ALPINE-CVE-2021-23336

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2021-23336

    The package python/cpython from 0 and before 3.6.13, from 3.7.0 and before 3.7.10, from 3.8.0 and before 3.8.8, from 3.9.0 and before 3.9.2 are vulnerable to Web Cache Poisoning via urllib.parse.parse_qsl and urllib.parse.parse_qs by using a vector called parameter cloaking. When the attacker can separate query parameters using a semicolon (;), they can cause a difference in the interpretation of the request between the proxy (running with default configuration) and the server. This can result in malicious requests being cached as completely safe ones, as the proxy would usually not see the semicolon as a separator, and therefore would not in

    • Update to 3.8.8-r0
    Published Updated
  13. ALPINE-CVE-2021-3177

    Critical · CVSS 9.8Fix available

    ALPINE-CVE-2021-3177

    Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrusted input, as demonstrated by a 1e300 argument to c_double.from_param. This occurs because sprintf is used unsafely.

    • Update to 3.8.7-r2
    Published Updated
  14. ALPINE-CVE-2020-14422

    Medium · CVSS 5.9Fix available

    ALPINE-CVE-2020-14422

    Lib/ipaddress.py in Python through 3.8.3 improperly computes hash values in the IPv4Interface and IPv6Interface classes, which might allow a remote attacker to cause a denial of service if an application is affected by the performance of a dictionary containing IPv4Interface or IPv6Interface objects, and this attacker can cause many dictionary entries to be created. This is fixed in: v3.5.10, v3.5.10rc1; v3.6.12; v3.7.9; v3.8.4, v3.8.4rc1, v3.8.5, v3.8.6, v3.8.6rc1; v3.9.0, v3.9.0b4, v3.9.0b5, v3.9.0rc1, v3.9.0rc2.

    • Update to 3.8.4-r0
    Published Updated
  15. ALPINE-CVE-2020-8492

    Medium · CVSS 6.5Fix available

    ALPINE-CVE-2020-8492

    Python 2.7 through 2.7.17, 3.5 through 3.5.9, 3.6 through 3.6.10, 3.7 through 3.7.6, and 3.8 through 3.8.1 allows an HTTP server to conduct Regular Expression Denial of Service (ReDoS) attacks against a client because of urllib.request.AbstractBasicAuthHandler catastrophic backtracking.

    • Update to 3.8.2-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →