p PatchFirst

PatchFirst · Latest vulnerabilities

nginx vulnerabilities

Vulnerabilities published for nginx in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. ALPINE-CVE-2018-16845

    Medium · CVSS 6.1Fix available

    ALPINE-CVE-2018-16845

    nginx before versions 1.15.6, 1.14.1 has a vulnerability in the ngx_http_mp4_module, which might allow an attacker to cause infinite loop in a worker process, cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted mp4 file. The issue only affects nginx if it is built with the ngx_http_mp4_module (the module is not built by default) and the .mp4. directive is used in the configuration file. Further, the attack is only possible if an attacker is able to trigger processing of a specially crafted mp4 file with the ngx_http_mp4_module.

    • Update to 1.12.1-r4
    Published Updated
  2. ALPINE-CVE-2018-16844

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-16844

    nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive CPU usage. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.

    • Update to 1.12.1-r4
    Published Updated
  3. ALPINE-CVE-2018-16843

    High · CVSS 7.5Fix available

    ALPINE-CVE-2018-16843

    nginx before versions 1.15.6 and 1.14.1 has a vulnerability in the implementation of HTTP/2 that can allow for excessive memory consumption. This issue affects nginx compiled with the ngx_http_v2_module (not compiled by default) if the 'http2' option of the 'listen' directive is used in a configuration file.

    • Update to 1.12.1-r4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →