p PatchFirst

PatchFirst · Latest vulnerabilities

varnish vulnerabilities

Vulnerabilities published for varnish in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. ALPINE-CVE-2017-8807

    Critical · CVSS 9.1Fix available

    ALPINE-CVE-2017-8807

    vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.

    • Update to 5.2.1-r0
    Published Updated
  2. ALPINE-CVE-2017-12425

    High · CVSS 7.5Fix available

    ALPINE-CVE-2017-12425

    An issue was discovered in Varnish HTTP Cache 4.0.1 through 4.0.4, 4.1.0 through 4.1.7, 5.0.0, and 5.1.0 through 5.1.2. A wrong if statement in the varnishd source code means that particular invalid requests from the client can trigger an assert, related to an Integer Overflow. This causes the varnishd worker process to abort and restart, losing the cached contents in the process. An attacker can therefore crash the varnishd worker process on demand and effectively keep it from serving content - a Denial-of-Service attack. The specific source-code filename containing the incorrect statement varies across releases.

    • Update to 5.1.3-r0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →