p PatchFirst

PatchFirst · Latest vulnerabilities

tauri-plugin-shell vulnerabilities

Vulnerabilities published for tauri-plugin-shell in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-31477

    Critical · CVSS 9.3EPSS 1.04%Fix available

    Improper Scope Validation in the open Endpoint of tauri-plugin-shell

    The Tauri shell plugin allows access to the system shell. Prior to 2.2.1, the Tauri shell plugin exposes functionality to execute code and open programs on the system. The open endpoint of this plugin is designed to allow open functionality with the system opener (e.g. xdg-open on Linux). This was meant to be restricted to a reasonable number of protocols like https or mailto by default. This default restriction was not functional due to improper validation of the allowed protocols, allowing for potentially dangerous protocols like file://, smb://, or nfs:// and others to be opened by the system registered protocol handler. By passing untrust

    • Update to 2.2.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →