p PatchFirst

CVE-2002-0640

CVE-2002-0640

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer overflow in sshd in OpenSSH 2.3.1 through 3.3 may allow remote attackers to execute arbitrary code via a large number of responses during challenge response authentication when OpenBSD is using PAM modules with interactive keyboard authentication (PAMAuthenticationViaKbdInt).

EPSS 28.2% · Public exploit · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssh Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:3.4

    Update to 1:3.4

  • openssh Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:3.4

    Update to 1:3.4

  • openssh Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:3.4

    Update to 1:3.4

Original sources

Check your server →