p PatchFirst

CVE-2004-0788

CVE-2004-0788

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow in the ICO image decoder for (1) gdk-pixbuf before 0.22 and (2) gtk2 before 2.2.4 allows remote attackers to cause a denial of service (application crash) via a crafted ICO file.

EPSS 5.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gdk-pixbuf Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.22.0-7

    Update to 0.22.0-7

  • gdk-pixbuf Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.22.0-7

    Update to 0.22.0-7

  • gdk-pixbuf Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.22.0-7

    Update to 0.22.0-7

  • gtk+2.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.4.9-2

    Update to 2.4.9-2

  • gtk+2.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.4.9-2

    Update to 2.4.9-2

  • gtk+2.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.4.9-2

    Update to 2.4.9-2

Original sources

Check your server →