p PatchFirst

PatchFirst · Latest vulnerabilities

gtk+2.0 vulnerabilities

Vulnerabilities published for gtk+2.0 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. CVE-2013-7447

    Medium · CVSS 6.5EPSS 4.63%Fix available

    CVE-2013-7447

    Integer overflow in the gdk_cairo_set_source_pixbuf function in gdk/gdkcairo.c in GTK+ before 3.9.8, as used in eom, gnome-photos, eog, gambas3, thunar, pinpoint, and possibly other applications, allows remote attackers to cause a denial of service (crash) via a large image file, which triggers a large memory allocation.

    • Update to 2.24.30-1.1
    Published Updated
  2. CVE-2015-4491

    Not ratedEPSS 8.4%Fix available

    CVE-2015-4491

    Integer overflow in the make_filter_table function in pixops/pixops.c in gdk-pixbuf before 2.31.5, as used in Mozilla Firefox before 40.0 and Firefox ESR 38.x before 38.2 on Linux, Google Chrome on Linux, and other products, allows remote attackers to execute arbitrary code or cause a denial of service (heap-based buffer overflow and application crash) via crafted bitmap dimensions that are mishandled during scaling.

    • Update to 2.21.5-1
    Published Updated
  3. CVE-2010-0732

    Not ratedEPSS 0.3%Fix available

    CVE-2010-0732

    gdk/gdkwindow.c in GTK+ before 2.18.5, as used in gnome-screensaver before 2.28.1, performs implicit paints on windows of type GDK_WINDOW_FOREIGN, which triggers an X error in certain circumstances and consequently allows physically proximate attackers to bypass screen locking and access an unattended workstation by pressing the Enter key many times.

    • Update to 2.18.5-1
    Published Updated
  4. CVE-2004-0783

    Not ratedEPSS 9.43%Fix available

    CVE-2004-0783

    Stack-based buffer overflow in xpm_extract_color (io-xpm.c) in the XPM image decoder for gtk+ 2.4.4 (gtk2) and earlier, and gdk-pixbuf before 0.22, may allow remote attackers to execute arbitrary code via a certain color string. NOTE: this identifier is ONLY for gtk+. It was incorrectly referenced in an advisory for a different issue (CVE-2004-0688).

    • Update to 2.4.9-2
    Published Updated
  5. CVE-2004-0782

    Not ratedEPSS 9.18%Fix available

    CVE-2004-0782

    Integer overflow in pixbuf_create_from_xpm (io-xpm.c) in the XPM image decoder for gtk+ 2.4.4 (gtk2) and earlier, and gdk-pixbuf before 0.22, allows remote attackers to execute arbitrary code via certain n_col and cpp values that enable a heap-based buffer overflow. NOTE: this identifier is ONLY for gtk+. It was incorrectly referenced in an advisory for a different issue (CVE-2004-0687).

    • Update to 2.4.9-2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →