p PatchFirst

CVE-2005-2491

CVE-2005-2491

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Integer overflow in pcre_compile.c in Perl Compatible Regular Expressions (PCRE) before 6.2, as used in multiple products such as Python, Ethereal, and PHP, allows attackers to execute arbitrary code via quantifier values in regular expressions, which leads to a heap-based buffer overflow.

EPSS 4.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnumeric Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.5.1-1

    Update to 1.5.1-1

  • gnumeric Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.5.1-1

    Update to 1.5.1-1

  • gnumeric Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.5.1-1

    Update to 1.5.1-1

  • goffice Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.1.0-3

    Update to 0.1.0-3

  • goffice Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.1.0-3

    Update to 0.1.0-3

  • goffice Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.1.0-3

    Update to 0.1.0-3

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 6.3-1

    Update to 6.3-1

Original sources

Check your server →