p PatchFirst

PatchFirst · Latest vulnerabilities

pcre3 vulnerabilities

Vulnerabilities published for pcre3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 52

  1. CVE-2015-2326

    Medium · CVSS 5.5EPSS 1.59%Fix available

    CVE-2015-2326

    The pcre_compile2 function in PCRE before 8.37 allows context-dependent attackers to compile incorrect code and cause a denial of service (out-of-bounds read) via regular expression with a group containing both a forward referencing subroutine call and a recursive back reference, as demonstrated by "((?+1)(\1))/".

    • Update to 2:8.35-7.2
    Published Updated
  2. CVE-2015-2325

    High · CVSS 7.8EPSS 1.59%Fix available

    CVE-2015-2325

    The compile_branch function in PCRE before 8.37 allows context-dependent attackers to compile incorrect code, cause a denial of service (out-of-bounds heap read and crash), or possibly have other unspecified impact via a regular expression with a group containing a forward reference repeated a large number of times within a repeated outer group that has a zero minimum quantifier.

    • Update to 2:8.35-7.2
    Published Updated
  3. CVE-2017-16231

    Medium · CVSS 5.5EPSS 0.54%No fix published

    CVE-2017-16231

    In PCRE 8.41, after compiling, a pcretest load test PoC produces a crash overflow in the function match() in pcre_exec.c because of a self-recursive call. NOTE: third parties dispute the relevance of this report, noting that there are options that can be used to limit the amount of stack that is used

    Published Updated
  4. CVE-2017-6004

    High · CVSS 7.5EPSS 4.55%Fix available

    CVE-2017-6004

    The compile_bracket_matchingpath function in pcre_jit_compile.c in PCRE through 8.x before revision 1680 (e.g., the PHP 7.1.1 bundled version) allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted regular expression.

    • Update to 2:8.39-2.1
    Published Updated
  5. CVE-2015-5073

    Critical · CVSS 9.1EPSS 7.67%Fix available

    CVE-2015-5073

    Heap-based buffer overflow in the find_fixedlength function in pcre_compile.c in PCRE before 8.38 allows remote attackers to cause a denial of service (crash) or obtain sensitive information from heap memory and possibly bypass the ASLR protection mechanism via a crafted regular expression with an excess closing parenthesis.

    • Update to 2:8.35-7
    Published Updated
  6. CVE-2015-3210

    Critical · CVSS 9.8EPSS 9.16%Fix available

    CVE-2015-3210

    Heap-based buffer overflow in PCRE 8.34 through 8.37 and PCRE2 10.10 allows remote attackers to execute arbitrary code via a crafted regular expression, as demonstrated by /^(?P=B)((?P=B)(?J:(?P<B>c)(?P<B>a(?P=B)))>WGXCREDITS)/, a different vulnerability than CVE-2015-8384.

    • Update to 2:8.35-7.2
    Published Updated
  7. CVE-2014-9769

    High · CVSS 7.3EPSS 2.35%Fix available

    CVE-2014-9769

    pcre_jit_compile.c in PCRE 8.35 does not properly use table jumps to optimize nested alternatives, which allows remote attackers to cause a denial of service (stack memory corruption) or possibly have unspecified other impact via a crafted string, as demonstrated by packets encountered by Suricata during use of a regular expression in an Emerging Threats Open ruleset.

    • Update to 2:8.38-1
    Published Updated
  8. CVE-2016-3191

    Critical · CVSS 9.8EPSS 8.43%Fix available

    CVE-2016-3191

    The compile_branch function in pcre_compile.c in PCRE 8.x before 8.39 and pcre2_compile.c in PCRE2 before 10.22 mishandles patterns containing an (*ACCEPT) substring in conjunction with nested parentheses, which allows remote attackers to execute arbitrary code or cause a denial of service (stack-based buffer overflow) via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, aka ZDI-CAN-3542.

    • Update to 2:8.38-2
    Published Updated
  9. CVE-2016-1283

    Critical · CVSS 9.8EPSS 7.79%Fix available

    CVE-2016-1283

    The pcre_compile2 function in pcre_compile.c in PCRE 8.38 mishandles the /((?:F?+(?:^(?(R)a+\"){99}-))(?J)(?'R'(?'R'<((?'RR'(?'R'\){97)?J)?J)(?'R'(?'R'\){99|(:(?|(?'R')(\k'R')|((?'R')))H'R'R)(H'R))))))/ pattern and related patterns with named subgroups, which allows remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

    • Update to 2:8.38-3.1
    Published Updated
  10. CVE-2015-8395

    Not ratedEPSS 3.54%Fix available

    CVE-2015-8395

    PCRE before 8.38 mishandles certain references, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, a related issue to CVE-2015-8384 and CVE-2015-8392.

    • Update to 2:8.38-1
    Published Updated
  11. CVE-2015-8392

    Not ratedEPSS 3.56%Fix available

    CVE-2015-8392

    PCRE before 8.38 mishandles certain instances of the (?| substring, which allows remote attackers to cause a denial of service (unintended recursion and buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, a related issue to CVE-2015-8384 and CVE-2015-8395.

    • Update to 2:8.38-1
    Published Updated
  12. CVE-2015-8388

    Not ratedEPSS 6.59%Fix available

    CVE-2015-8388

    PCRE before 8.38 mishandles the /(?=di(?<=(?1))|(?=(.))))/ pattern and related patterns with an unmatched closing parenthesis, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

    • Update to 2:8.35-7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →