p PatchFirst

CVE-2005-2976

CVE-2005-2976

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Integer overflow in io-xpm.c in gdk-pixbuf 0.22.0 in GTK+ before 2.8.7 allows attackers to cause a denial of service (crash) or execute arbitrary code via an XPM file with large height, width, and colour values, a different vulnerability than CVE-2005-3186.

EPSS 4.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gdk-pixbuf Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.22.0-11

    Update to 0.22.0-11

  • gdk-pixbuf Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.22.0-11

    Update to 0.22.0-11

  • gdk-pixbuf Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.22.0-11

    Update to 0.22.0-11

  • gtk+2.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.6.10-2

    Update to 2.6.10-2

  • gtk+2.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.6.10-2

    Update to 2.6.10-2

  • gtk+2.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.6.10-2

    Update to 2.6.10-2

Original sources

Check your server →