p PatchFirst

CVE-2006-2940

CVE-2006-2940

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

OpenSSL 0.9.7 before 0.9.7l, 0.9.8 before 0.9.8d, and earlier versions allows attackers to cause a denial of service (CPU consumption) via parasitic public keys with large (1) "public exponent" or (2) "public modulus" values in X.509 certificates that require extra time to process when using RSA signature verification.

EPSS 5.1% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.9.8c-2

    Update to 0.9.8c-2

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.9.8c-2

    Update to 0.9.8c-2

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.9.8c-2

    Update to 0.9.8c-2

Original sources

Check your server →