p PatchFirst

CVE-2006-7225

CVE-2006-7225

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to cause a denial of service (error or crash) via a regular expression that involves a "malformed POSIX character class", as demonstrated via an invalid character after a [[ sequence.

EPSS 1.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glib2.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • glib2.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • glib2.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 6.7-1

    Update to 6.7-1

Original sources

Check your server →