p PatchFirst

CVE-2007-1662

CVE-2007-1662

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Perl-Compatible Regular Expression (PCRE) library before 7.3 reads past the end of the string when searching for unmatched brackets and parentheses, which allows context-dependent attackers to cause a denial of service (crash), possibly involving forward references.

EPSS 2.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glib2.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • glib2.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • glib2.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.3-1

    Update to 7.3-1

Original sources

Check your server →