p PatchFirst

CVE-2007-3215

CVE-2007-3215

This page contains facts from public vulnerability sources. Check the original advisory before updating.

PHPMailer 1.7, when configured to use sendmail, allows remote attackers to execute arbitrary shell commands via shell metacharacters in the SendmailSend function in class.phpmailer.php.

EPSS 2.4% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libphp-phpmailer Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.73-4

    Update to 1.73-4

  • libphp-phpmailer Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.73-4

    Update to 1.73-4

  • libphp-phpmailer Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.73-4

    Update to 1.73-4

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.1-1

    Update to 2.2.1-1

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.1-1

    Update to 2.2.1-1

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.1-1

    Update to 2.2.1-1

  • phpmailer/phpmailer Packagist

    Affected ranges
    • ECOSYSTEM: < 1.7.4

    Update to 1.7.4

Original sources

Check your server →