p PatchFirst

PatchFirst · Latest vulnerabilities

phpmailer/phpmailer vulnerabilities

Vulnerabilities published for phpmailer/phpmailer in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. CVE-2021-3603

    High · CVSS 8.1EPSS 2.26%Fix available

    Inclusion of Functionality from Untrusted Control Sphere in PHPMailer/PHPMailer

    PHPMailer 6.4.1 and earlier contain a vulnerability that can result in untrusted code being called (if such code is injected into the host project's scope by other means). If the $patternselect parameter to validateAddress() is set to 'php' (the default, defined by PHPMailer::$validator), and the global namespace contains a function called php, it will be called in preference to the built-in validator of the same name. Mitigated in PHPMailer 6.5.0 by denying the use of simple strings as validator function names.

    • Update to 6.5.0
    Published Updated
  2. CVE-2020-36326

    Critical · CVSS 9.8EPSS 3.09%Fix available

    CVE-2020-36326

    PHPMailer 6.1.8 through 6.4.0 allows object injection through Phar Deserialization via addAttachment with a UNC pathname. NOTE: this is similar to CVE-2018-19296, but arose because 6.1.8 fixed a functionality problem in which UNC pathnames were always considered unreadable by PHPMailer, even in safe contexts. As an unintended side effect, this fix eliminated the code that blocked addAttachment exploitation.

    • Update to 6.4.1
    Published Updated
  3. CVE-2017-5223

    Medium · CVSS 5.5EPSS 2.14%Public exploitFix available

    CVE-2017-5223

    An issue was discovered in PHPMailer before 5.2.22. PHPMailer's msgHTML method applies transformations to an HTML document to make it usable as an email message body. One of the transformations is to convert relative image URLs into attachments using a script-provided base directory. If no base directory is provided, it resolves to /, meaning that relative image URLs get treated as absolute local file paths and added as attachments. To form a remote vulnerability, the msgHTML method must be called, passed an unfiltered, user-supplied HTML document, and must not set a base directory.

    • Update to 5.2.22
    Published Updated
  4. CVE-2016-10045

    Critical · CVSS 9.8EPSS 97.74%Public exploitFix available

    CVE-2016-10045

    The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code by leveraging improper interaction between the escapeshellarg function and internal escaping performed in the mail function in PHP. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-10033.

    • Update to 5.2.20
    Published Updated
  5. CVE-2015-8476

    Not ratedEPSS 1.99%Fix available

    CVE-2015-8476

    Multiple CRLF injection vulnerabilities in PHPMailer before 5.2.14 allow attackers to inject arbitrary SMTP commands via CRLF sequences in an (1) email address to the validateAddress function in class.phpmailer.php or (2) SMTP command to the sendCommand function in class.smtp.php, a different vulnerability than CVE-2012-0796.

    • Update to 5.2.14
    Published Updated
  6. CVE-2012-0796

    Not ratedEPSS 1.68%Fix available

    CVE-2012-0796

    class.phpmailer.php in the PHPMailer library, as used in Moodle 1.9.x before 1.9.16, 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 and other products, allows remote authenticated users to inject arbitrary e-mail headers via vectors involving a crafted (1) From: or (2) Sender: header.

    • Update to 2.2.1
    Published Updated
  7. CVE-2008-5619

    Not ratedEPSS 58.64%Public exploitFix available

    CVE-2008-5619

    html2text.php in Chuggnutt HTML to Text Converter, as used in PHPMailer before 5.2.10, RoundCube Webmail (roundcubemail) 0.2-1.alpha and 0.2-3.beta, Mahara, and AtMail Open 1.03, allows remote attackers to execute arbitrary code via crafted input that is processed by the preg_replace function with the eval switch.

    • Update to 5.2.10
    Published Updated
  8. CVE-2006-5734

    Not ratedEPSS 1.47%Fix available

    CVE-2006-5734

    Multiple PHP remote file inclusion vulnerabilities in ATutor 1.5.3.2 allow remote attackers to execute arbitrary PHP code via a URL in the (1) section parameter in (a) documentation/common/frame_toc.php and (b) documentation/common/search.php, the (2) req_lang parameter in documentation/common/search.php and (c) documentation/common/vitals.inc.php, the (3) row[dir_name] parameter in (d) include/classes/module/module.class.php, and the (4) lang_path parameter in (e) include/classes/phpmailer/class.phpmailer.php. NOTE: the print.php vector is already covered by CVE-2005-3404.

    • Update to 5.2.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →