p PatchFirst

CVE-2007-4029

CVE-2007-4029

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

libvorbis 1.1.2, and possibly other versions before 1.2.0, allows context-dependent attackers to cause a denial of service via (1) an invalid mapping type, which triggers an out-of-bounds read in the vorbis_info_clear function in info.c, and (2) invalid blocksize values that trigger a segmentation fault in the read function in block.c.

EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libvorbis Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.0.dfsg-1

    Update to 1.2.0.dfsg-1

  • libvorbis Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.2.0.dfsg-1

    Update to 1.2.0.dfsg-1

  • libvorbis Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.2.0.dfsg-1

    Update to 1.2.0.dfsg-1

  • libvorbisidec Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.2+svn16259-2

    Update to 1.0.2+svn16259-2

  • libvorbisidec Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.2+svn16259-2

    Update to 1.0.2+svn16259-2

  • libvorbisidec Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.2+svn16259-2

    Update to 1.0.2+svn16259-2

Original sources

Check your server →