p PatchFirst

PatchFirst · Latest vulnerabilities

libvorbis vulnerabilities

Vulnerabilities published for libvorbis in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 18

  1. CVE-2012-0444

    Not ratedEPSS 7.84%Fix available

    CVE-2012-0444

    Mozilla Firefox before 3.6.26 and 4.x through 9.0, Thunderbird before 3.1.18 and 5.0 through 9.0, and SeaMonkey before 2.7 do not properly initialize nsChildView data structures, which allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a crafted Ogg Vorbis file.

    • Update to 1.3.2-1.2
    Published Updated
  2. CVE-2008-1423

    Not ratedEPSS 8.13%Fix available

    CVE-2008-1423

    Integer overflow in a certain quantvals and quantlist calculation in Xiph.org libvorbis 1.2.0 and earlier allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted OGG file with a large virtual space for its codebook, which triggers a heap overflow.

    • Update to 1.2.0.dfsg-3.1
    Published Updated
  3. CVE-2007-4066

    Not ratedEPSS 1.84%Fix available

    CVE-2007-4066

    Multiple buffer overflows in Xiph.Org libvorbis before 1.2.0 allow context-dependent attackers to cause a denial of service or have other unspecified impact via a crafted OGG file, aka trac Changesets 13162, 13168, 13169, 13170, 13172, 13211, and 13215, as demonstrated by an overflow in oggenc.exe related to the _psy_noiseguards_8 array.

    • Update to 1.2.0.dfsg-1
    Published Updated
  4. CVE-2007-4029

    Not ratedEPSS 1.67%Fix available

    CVE-2007-4029

    libvorbis 1.1.2, and possibly other versions before 1.2.0, allows context-dependent attackers to cause a denial of service via (1) an invalid mapping type, which triggers an out-of-bounds read in the vorbis_info_clear function in info.c, and (2) invalid blocksize values that trigger a segmentation fault in the read function in block.c.

    • Update to 1.2.0.dfsg-1
    Published Updated
  5. CVE-2007-3106

    Not ratedEPSS 3.14%Fix available

    CVE-2007-3106

    lib/info.c in libvorbis 1.1.2, and possibly other versions before 1.2.0, allows context-dependent attackers to cause a denial of service and possibly execute arbitrary code via invalid (1) blocksize_0 and (2) blocksize_1 values, which trigger a "heap overwrite" in the _01inverse function in res0.c. NOTE: this issue has been RECAST so that CVE-2007-4029 handles additional vectors.

    • Update to 1.2.0.dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →