p PatchFirst

CVE-2007-4768

CVE-2007-4768

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Heap-based buffer overflow in Perl-Compatible Regular Expression (PCRE) library before 7.3 allows context-dependent attackers to execute arbitrary code via a singleton Unicode sequence in a character class in a regex pattern, which is incorrectly optimized.

EPSS 4.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glib2.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • glib2.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • glib2.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.14.3-1

    Update to 2.14.3-1

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.3-1

    Update to 7.3-1

Original sources

Check your server →