p PatchFirst

CVE-2008-4796

CVE-2008-4796

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

EPSS 9.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libphp-snoopy Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.4-1

    Update to 1.2.4-1

  • wordpress Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.5.1-9

    Update to 2.5.1-9

  • wordpress Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.5.1-9

    Update to 2.5.1-9

  • wordpress Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.5.1-9

    Update to 2.5.1-9

Original sources

Check your server →