p PatchFirst

CVE-2009-0653

CVE-2009-0653

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenSSL, probably 0.9.6, does not verify the Basic Constraints for an intermediate CA-signed certificate, which allows remote attackers to spoof the certificates of trusted sites via a man-in-the-middle attack, a related issue to CVE-2002-0970.

EPSS 1.1% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.9.8-1

    Update to 0.9.8-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.9.8-1

    Update to 0.9.8-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.9.8-1

    Update to 0.9.8-1

Original sources

Check your server →