p PatchFirst

CVE-2009-2412

CVE-2009-2412

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple integer overflows in the Apache Portable Runtime (APR) library and the Apache Portable Utility library (aka APR-util) 0.9.x and 1.3.x allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors that trigger crafted calls to the (1) allocator_alloc or (2) apr_palloc function in memory/unix/apr_pools.c in APR; or crafted calls to the (3) apr_rmm_malloc, (4) apr_rmm_calloc, or (5) apr_rmm_realloc function in misc/apr_rmm.c in APR-util; leading to buffer overflows. NOTE: some of these details are obtained from third party information.

EPSS 13.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • apr Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.3.8-1

    Update to 1.3.8-1

  • apr Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.3.8-1

    Update to 1.3.8-1

  • apr Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.3.8-1

    Update to 1.3.8-1

  • apr-util Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.3.9+dfsg-1

    Update to 1.3.9+dfsg-1

  • apr-util Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.3.9+dfsg-1

    Update to 1.3.9+dfsg-1

  • apr-util Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.3.9+dfsg-1

    Update to 1.3.9+dfsg-1

Original sources

Check your server →