p PatchFirst

PatchFirst · Latest vulnerabilities

apr-util vulnerabilities

Vulnerabilities published for apr-util in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 12

  1. CVE-2025-49506

    High · CVSS 7.5EPSS 0.38%Fix available

    Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

    APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Update to 1.6.3-3+deb13u1
    Published Updated
  2. CVE-2026-32327

    Critical · CVSS 9.1EPSS 0.46%Fix available

    Apache Portable Runtime Utility: apr-util XML stack recursion crash

    A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.

    • Update to 1.6.3-3+deb13u1
    Published Updated
  3. CVE-2026-34191

    Critical · CVSS 9.1EPSS 0.59%Fix available

    Apache Portable Runtime Utility: SQL Injection in apr_dbd_oracle

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Portable Runtime Utility via apr_dbd_oracle provider. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3

    • Update to 1.6.3-3+deb13u1
    Published Updated
  4. CVE-2026-34501

    High · CVSS 7.5EPSS 0.51%Fix available

    Apache Portable Runtime Utility: Heap buffer overflow in APR redis client

    Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.

    • Update to 1.6.3-3+deb13u1
    Published Updated
  5. CVE-2022-25147

    Medium · CVSS 6.5EPSS 1.42%Fix available

    Apache Portable Runtime Utility (APR-util): out-of-bounds writes in the apr_base64 family of functions

    Integer Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.

    • Update to 1.6.3-1
    Published Updated
  6. CVE-2017-12618

    Medium · CVSS 4.7EPSS 0.6%Fix available

    CVE-2017-12618

    Apache Portable Runtime Utility (APR-util) 1.6.0 and prior fail to validate the integrity of SDBM database files used by apr_sdbm*() functions, resulting in a possible out of bound read access. A local user with write access to the database can make a program or process using these functions crash, and cause a denial of service.

    • Update to 1.6.1-1
    Published Updated
  7. CVE-2010-1623

    Not ratedEPSS 20.33%Fix available

    CVE-2010-1623

    Memory leak in the apr_brigade_split_line function in buckets/apr_brigade.c in the Apache Portable Runtime Utility library (aka APR-util) before 1.3.10, as used in the mod_reqtimeout module in the Apache HTTP Server and other software, allows remote attackers to cause a denial of service (memory consumption) via unspecified vectors related to the destruction of an APR bucket.

    • Update to 1.3.9+dfsg-4
    Published Updated
  8. CVE-2009-2412

    Not ratedEPSS 13.78%Fix available

    CVE-2009-2412

    Multiple integer overflows in the Apache Portable Runtime (APR) library and the Apache Portable Utility library (aka APR-util) 0.9.x and 1.3.x allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors that trigger crafted calls to the (1) allocator_alloc or (2) apr_palloc function in memory/unix/apr_pools.c in APR; or crafted calls to the (3) apr_rmm_malloc, (4) apr_rmm_calloc, or (5) apr_rmm_realloc function in misc/apr_rmm.c in APR-util; leading to buffer overflows. NOTE: some of these details are obtained from third party information.

    • Update to 1.3.9+dfsg-1
    Published Updated
  9. CVE-2009-1955

    High · CVSS 7.5EPSS 52.99%Public exploitFix available

    CVE-2009-1955

    The expat XML parser in the apr_xml_* interface in xml/apr_xml.c in Apache APR-util before 1.3.7, as used in the mod_dav and mod_dav_svn modules in the Apache HTTP Server, allows remote attackers to cause a denial of service (memory consumption) via a crafted XML document containing a large number of nested entity references, as demonstrated by a PROPFIND request, a similar issue to CVE-2003-1564.

    • Update to 1.3.7+dfsg-1
    Published Updated
  10. CVE-2009-0023

    Not ratedEPSS 8.53%Fix available

    CVE-2009-0023

    The apr_strmatch_precompile function in strmatch/apr_strmatch.c in Apache APR-util before 1.3.5 allows remote attackers to cause a denial of service (daemon crash) via crafted input involving (1) a .htaccess file used with the Apache HTTP Server, (2) the SVNMasterURI directive in the mod_dav_svn module in the Apache HTTP Server, (3) the mod_apreq2 module for the Apache HTTP Server, or (4) an application that uses the libapreq2 library, which triggers a heap-based buffer underflow.

    • Update to 1.3.7+dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →