p PatchFirst

CVE-2009-2663

CVE-2009-2663

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libvorbis before r16182, as used in Mozilla Firefox 3.5.x before 3.5.2 and other products, allows context-dependent attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a crafted .ogg file.

EPSS 2.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libvorbis Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.2.0.dfsg-6

    Update to 1.2.0.dfsg-6

  • libvorbis Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.2.0.dfsg-6

    Update to 1.2.0.dfsg-6

  • libvorbis Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.2.0.dfsg-6

    Update to 1.2.0.dfsg-6

  • libvorbisidec Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.0.2+svn16259-2

    Update to 1.0.2+svn16259-2

  • libvorbisidec Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.0.2+svn16259-2

    Update to 1.0.2+svn16259-2

  • libvorbisidec Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.0.2+svn16259-2

    Update to 1.0.2+svn16259-2

Original sources

Check your server →