p PatchFirst

CVE-2010-1104

CVE-2010-1104

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

EPSS 2.0% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • zope2 PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 2.8.0, < 2.8.12

    Update to 2.8.12

  • zope2 PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 2.9.0, < 2.9.12

    Update to 2.9.12

  • zope2 PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 2.10.0, < 2.10.11

    Update to 2.10.11

  • zope2 PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 2.11.0, < 2.11.6

    Update to 2.11.6

  • zope2 PyPI

    Versions
    • 2.12.0
    • 2.12.1
    • 2.12.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.12.0, < 2.12.3

    Update to 2.12.3

  • zope2 PyPI

    Versions
    • 2.12.0
    • 2.12.1
    • 2.12.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.8.0, < 2.8.12 ∪ ≥ 2.9.0, < 2.9.12 ∪ ≥ 2.10.0, < 2.10.11 ∪ ≥ 2.11.0, < 2.11.6 ∪ ≥ 2.12.0, < 2.12.3

    Update to 2.8.12; Update to 2.9.12; Update to 2.10.11; Update to 2.11.6; Update to 2.12.3

Original sources

Check your server →