p PatchFirst

PatchFirst · Latest vulnerabilities

zope2 vulnerabilities

Vulnerabilities published for zope2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 11

  1. CVE-2011-4924

    Medium · CVSS 6.1EPSS 1.36%Fix available

    CVE-2011-4924

    Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

    • Update to 2.12.22
    • Update to 2.13.12
    Published Updated
  2. CVE-2012-6661

    High · CVSS 8.7EPSS 2.38%Fix available

    CVE-2012-6661

    Zope before 2.13.19, as used in Plone before 4.2.3 and 4.3 before beta 1, does not reseed the pseudo-random number generator (PRNG), which makes it easier for remote attackers to guess the value via unspecified vectors. NOTE: this issue was SPLIT from CVE-2012-5508 due to different vulnerability types (ADT2).

    • Update to 2.13.19
    Published Updated
  3. CVE-2012-5489

    High · CVSS 7.1EPSS 1.94%Fix available

    CVE-2012-5489

    The App.Undo.UndoSupport.get_request_var_or_attr function in Zope before 2.12.21 and 3.13.x before 2.13.11, as used in Plone before 4.2.3 and 4.3 before beta 1, allows remote authenticated users to gain access to restricted attributes via unspecified vectors.

    • Update to 2.12.21
    • Update to 2.13.11
    Published Updated
  4. CVE-2011-3587

    Not ratedEPSS 78.08%Public exploitFix available

    CVE-2011-3587

    Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attackers to execute arbitrary commands via vectors related to the p_ class in OFS/misc_.py and the use of Python modules.

    • Update to 2.12.20
    • Update to 2.13.10
    Published Updated
  5. CVE-2011-2528

    Not ratedEPSS 2.03%Fix available

    CVE-2011-2528

    Unspecified vulnerability in (1) Zope 2.12.x before 2.12.19 and 2.13.x before 2.13.8, as used in Plone 4.x and other products, and (2) PloneHotfix20110720 for Plone 3.x allows attackers to gain privileges via unspecified vectors, related to a "highly serious vulnerability." NOTE: this vulnerability exists because of an incorrect fix for CVE-2011-0720.

    • Update to 2.12.19
    • Update to 2.13.8
    Published Updated
  6. CVE-2010-1104

    Not ratedEPSS 1.96%Fix available

    CVE-2010-1104

    Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3 allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

    • Update to 2.10.11
    • Update to 2.11.6
    • Update to 2.12.3
    • Update to 2.8.12
    • Update to 2.9.12
    Published Updated
  7. CVE-2006-4684

    Not ratedEPSS 2.45%Fix available

    CVE-2006-4684

    The docutils module in Zope (Zope2) 2.7.0 through 2.7.9 and 2.8.0 through 2.8.8 does not properly handle web pages with reStructuredText (reST) markup, which allows remote attackers to read arbitrary files via a csv_table directive, a different vulnerability than CVE-2006-3458.

    • Update to 2.8.9
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →